Repositório de testes

 

AVISO: Compatível apenas com o Pipplware 5.0 e superior

Para além do repositório normal, o PiPplware conta também com dois repositórios “unstable”, que contém software em fase de testes, como por exemplo versões beta do Kodi. Só é recomendado activar estes repositórios se tiverem um backup dos vossos dados e desejarem experimentar e testar as ultimas versões do software disponível, que eventualmente mais tarde irão passar ao repositório normal e fazer parte da próxima versão do PiPplware.

AVISO: Software aqui presente pode conter bugs, causar perda de dados ou mesmo deixar o sistema inoperacional! Usem por vossa conta e risco.

 

Repositório de testes ARMv6 (compatível com todas as versões do Raspberry):

Este repositório contém software para todas as versões do Raspberry Pi.

  • Para activar o repositório de testes ARMv6 e actualizar, executar num terminal (não esquecer de fechar antes programas abertos como por exemplo o Kodi):
sudo su
echo "deb http://pipplware.pplware.pt/pipplware/dists/unstable/main/binary /" > /etc/apt/sources.list.d/pipplware_unstable.list
apt-get update && apt-get dist-upgrade -y
exit

Posteriormente, actualizar o sistema com este repositório activo funciona de forma igual ao normal, ou seja, no Emulation Station ou XFCE -> Settings -> Update System

  • Para remover o repositório de testes e voltar ao normal, executar num terminal:
sudo rm /etc/apt/sources.list.d/pipplware_unstable.list
sudo apt-get update -y

 

Repositório de testes ARMv7 (compatível apenas com o Raspberry Pi 2 e 3):

Este repositório contém software optimizado para o Raspberry Pi 2 e 3, portanto software aqui incluído não irá funcionar em outras versões do Raspberry Pi.

  • Para activar o repositório de testes ARMv7 e actualizar, executar num terminal (não esquecer de fechar antes programas abertos como por exemplo o Kodi):
sudo su
echo "deb http://pipplware.pplware.pt/pipplware/dists/unstable/main/binary /" > /etc/apt/sources.list.d/pipplware_unstable_armv7.list
echo "deb http://pipplware.pplware.pt/pipplware/dists/unstable/armv7/binary /" >> /etc/apt/sources.list.d/pipplware_unstable_armv7.list
apt-get update && apt-get dist-upgrade -y
exit

Posteriormente, actualizar o sistema com este repositório activo funciona de forma igual ao normal, ou seja, no Emulation Station ou XFCE -> Settings -> Update System

  • Para remover o repositório de testes e voltar ao normal, executar num terminal:
sudo rm /etc/apt/sources.list.d/pipplware_unstable_armv7.list
sudo apt-get update -y